View Issue Details

IDProjectCategoryView StatusLast Update
0000116VisualDifferFiles differpublic2012-07-31 17:56
ReporterwayneljwAssigned Toadmin 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformMacOSOSXOS VersionLion 10.7.4
Product Version1.4.2 
Target VersionFixed in Version1.4.3 
Summary0000116: Does not work with Dreamweaver any more after upgrading to 1.4.2
DescriptionNote: this bug report is for version 1.4.2
Because there is no such option in the "Product version" drop-down, I selected 1.4.1

After Upgrading to 1.4.2, this product doen't work with Dreamweaver any more.
When I execute "compare with remote", it runs, but then it claims that the remove file is incorrect (and it shows me a finder window for me to manually select the temp file downloaded from remove). Then it says the local file is incorrect (again, it shows another finder window for me to manually select the local file). If I select the file from the finder window, the comparison window shows successfully. In the previous version, we don't have to manually select the files.

In Dreamweaver, The command I setup is: "Macintosh HD:Applications:VisualDiffer.app:Contents:Resources:visdiff"

or "/usr/bin/visdiff" (if I have executed the command instructed at http://wiki.visualdiffer.com/index.php/Unix_Shell_Scripting_Support)

Note: the setting for dreamweaver can be found here:
help.adobe.com/en_US/dreamweaver/cs/using/WSc78c5058ca073340dcda9110b1f693f21-7edda.html
Steps To Reproducein Dreamweaver, right click on a file and select "compare with remote".

In version 1.4.1: files can be successfully compared

in version 1.4.2: it claims files are incorrect and we need to manually select the file from the finder window.
TagsNo tags attached.

Activities

admin

2012-07-09 10:52

administrator   ~0000125

Apple changed rules for sandboxed apps (eg apps running on Lion and above), I've submitted version 1.4.3 with a fix and I'm waiting Apple approval (I hope an a few days)

Please wait for v1.4.3

Please apologize me for inconvenient

admin

2012-07-15 08:00

administrator   ~0000126

Updated documentation
http://wiki.visualdiffer.com/index.php/Unix_Shell_Scripting_Support#OSX_sandbox.2C_temporary_files_and_annoying_file_open_panel_prompts

Waiting for Apple approval...

Due to slow Apple approval process, a bug fixed quickly requires weeks before users can use the fixed version :(

Issue History

Date Modified Username Field Change
2012-07-09 10:13 wayneljw New Issue
2012-07-09 10:13 wayneljw Status new => assigned
2012-07-09 10:13 wayneljw Assigned To => admin
2012-07-09 10:52 admin Note Added: 0000125
2012-07-09 10:52 admin Product Version 1.4.1 => 1.4.2
2012-07-15 08:00 admin Note Added: 0000126
2012-07-31 17:56 admin Status assigned => closed
2012-07-31 17:56 admin Resolution open => fixed
2012-07-31 17:56 admin Fixed in Version => 1.4.3