View Issue Details

IDProjectCategoryView StatusLast Update
0000117VisualDifferGeneralpublic2012-07-31 17:56
ReporterHeathy65Assigned Toadmin 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformMacOSOS XOS Version10.7.4
Product Version1.4.2 
Target VersionFixed in Version1.4.3 
Summary0000117: Can't delete files from NAS
DescriptionI have a share from my Synology DiskStation NAS which holds some files (photos).

I can deleted these files from my MBP when logged in as myself but if I run VisualDiffer and try to delete the same files then I get the following error:

/Volumes/photo2COPIED/100NIKON/DSCN2339.JPG: “DSCN2339.JPG” couldn’t be removed because you don’t have permission to access it.

Also if I try to delete a folder on the same NAS then I get this error:

/Volumes/photo2COPIED/100NIKON/Thumbs.db: “Thumbs.db” couldn’t be removed because you don’t have permission to access it.
/Volumes/photo2COPIED/100NIKON/DSCN3014.JPG: “DSCN3014.JPG” couldn’t be removed because you don’t have permission to access it.
/Volumes/photo2COPIED/100NIKON/DSCN3013.JPG: “DSCN3013.JPG” couldn’t be removed because you don’t have permission to access it.
/Volumes/photo2COPIED/100NIKON/DSCN2348.JPG: “DSCN2348.JPG” couldn’t be removed because you don’t have permission to access it.
/Volumes/photo2COPIED/100NIKON/DSCN2347.JPG: “DSCN2347.JPG” couldn’t be removed because you don’t have permission to access it.
/Volumes/photo2COPIED/100NIKON/DSCN2344.JPG: “DSCN2344.JPG” couldn’t be removed because you don’t have permission to access it.
/Volumes/photo2COPIED/100NIKON/DSCN2343.JPG: “DSCN2343.JPG” couldn’t be removed because you don’t have permission to access it.
/Volumes/photo2COPIED/100NIKON/DSCN2341.JPG: “DSCN2341.JPG” couldn’t be removed because you don’t have permission to access it.
/Volumes/photo2COPIED/100NIKON/DSCN2340.JPG: “DSCN2340.JPG” couldn’t be removed because you don’t have permission to access it.
/Volumes/photo2COPIED/100NIKON/DSCN2339.JPG: “DSCN2339.JPG” couldn’t be removed because you don’t have permission to access it.
/Volumes/photo2COPIED/100NIKON: “100NIKON” couldn’t be removed because you don’t have permission to access it.

Then the GUI shows the folder as deleted (which it isn't), but the files are still shown in the GUI (see attached file).
TagsNo tags attached.

Activities

admin

2012-07-22 16:13

administrator   ~0000127

This bug is related to bug 116 http://bugs.visualdiffer.com/view.php?id=116

I've submitted a fix but Apple hasn't approved yet.

Please apologize for the problem but until Apple doesn't approve the v1.4.3 the problem will persist.

Maybe Apple waits for Mountain Lion launch before approve submitted apps revision

Issue History

Date Modified Username Field Change
2012-07-22 16:06 Heathy65 New Issue
2012-07-22 16:06 Heathy65 Status new => assigned
2012-07-22 16:06 Heathy65 Assigned To => admin
2012-07-22 16:13 admin Note Added: 0000127
2012-07-31 17:56 admin Status assigned => closed
2012-07-31 17:56 admin Resolution open => fixed
2012-07-31 17:56 admin Fixed in Version => 1.4.3