View Issue Details

IDProjectCategoryView StatusLast Update
0000121VisualDifferGeneralpublic2013-04-11 15:49
ReporteraftimgAssigned Toadmin 
PriorityimmediateSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version1.4.3 
Target VersionFixed in Version1.5.3 
Summary0000121: copy does not preserve source file time stamps
Descriptionwhen i copy files and folders the creation time stamp is not preserved.

the default should be to preserve the creation date and modification date so that they diff as a match after the copy
Steps To Reproducecopy a file and a dir
TagsNo tags attached.

Activities

admin

2012-08-02 07:21

administrator   ~0000131

Last edited: 2012-08-02 07:22

View 2 revisions

The current behavior copies also the modification date and running a successive comparison finds files as "equal" using "Compare file timestamps" as comparison method.

Please tell me more about copied files:

File size
Disk Partition or device type: hfs? external usb drive? time machine disk?
OS version

VisualDiffer uses two different copy methods to speedup big files so also file size is important to reproduce the bug

aftimg

2012-08-02 08:40

reporter   ~0000132

all i can tell you is that the creation and modification date gets changed on copy left and copy right menu options. any file size. local or mounted.

when i copy a file over and recheck the diff based on time it shows it a miss-match.

there are 2 ways to copy files in unix. preserving the time stamps or not. change your code so that the timestamps are always preserved, or provide multiple copy menu options.

aftimg

2012-08-02 08:45

reporter   ~0000133

see your own menu - actions>set modification date

this is should be automatically a choice in the copy - not just an after-fix.

admin

2012-08-02 08:58

administrator   ~0000134

Modification date of Destination file is set to source file by default.

I don't do any special task, this is done the the Apple copy routine VisualDiffer uses

aftimg

2012-08-02 09:08

reporter   ~0000135

that's what I'm saying.

you're calling the wrong copy or not passing the arguments such that the time stamps are preserved.

aftimg

2012-08-02 09:11

reporter   ~0000136

Last edited: 2012-08-05 19:40

View 2 revisions

also it looks like your set modification date function does not sync to the second - just the minute - but that appears to be intermittent

Issue History

Date Modified Username Field Change
2012-08-02 04:25 aftimg New Issue
2012-08-02 04:25 aftimg Status new => assigned
2012-08-02 04:25 aftimg Assigned To => admin
2012-08-02 07:21 admin Note Added: 0000131
2012-08-02 07:22 admin Note Edited: 0000131 View Revisions
2012-08-02 08:40 aftimg Note Added: 0000132
2012-08-02 08:45 aftimg Note Added: 0000133
2012-08-02 08:58 admin Note Added: 0000134
2012-08-02 09:08 aftimg Note Added: 0000135
2012-08-02 09:11 aftimg Note Added: 0000136
2012-08-05 19:40 aftimg Note Edited: 0000136 View Revisions
2013-04-11 15:49 admin Status assigned => closed
2013-04-11 15:49 admin Resolution open => fixed
2013-04-11 15:49 admin Fixed in Version => 1.5.3