View Issue Details

IDProjectCategoryView StatusLast Update
0000123VisualDifferFiles differpublic2013-04-13 10:23
ReporterevolutionAssigned Toadmin 
PrioritynormalSeveritymajorReproducibilityalways
Status assignedResolutionreopened 
PlatformMacOSOS XOS Version10.8
Product Version1.4.3 
Target VersionFixed in Version 
Summary0000123: files ending in ".zip" are totally excluded from view and analysis by VisualDiffer
DescriptionI had a folder containing zipped files in a comparison by VisualDiffer.
VisualDiffer did not show them on screen, nor include them in the comparison, nor copy them when asked to copy the parent folder.

Note that I am NOT talking about the content of zipped files, but any actual file whose name ends in ".zip"

As a test, I took a regular jpeg file, duplicated it in place and simply renamed by adding ".zip" at the end; VisualDiffer was seeing the ".jpg" file but not the ".zip" file
Steps To ReproduceInclude any file named xyz.zip in a folder and use that folder in a comparison
TagsNo tags attached.

Activities

evolution

2012-08-05 07:44

reporter   ~0000140

Last edited: 2012-08-05 07:44

View 2 revisions

1- By the way, I did not set any filter to omit ".zip" files. I just used the app as it comes by default

2- I find this issue very serious as I cannot trust the outcome. Data loss very likely.
If 2 folders are found the same, can I delete one of them? Wrong! Since the folder I choose to delete could contain the only copy of some ".zip" files that VisualDiffer did not report.

What other kind of files could possibly go unreported? Sadly, this lowers overall confidence in the product.

admin

2012-08-05 08:09

administrator   ~0000141

By default VisualDiffer omits many files, expecially *.zip, *.tar and so on.

You need to change the default filter set using the toolbar button 'Exclusion filters'

This should fix the problem

evolution

2012-08-05 08:22

reporter   ~0000142

aarrrghh! I am horrified to discover that the app has a default filter in place for many file types, I never expected that, it doesn't make sense!

Filtering didn't fit my purpose for now, so I never bothered to look at it, or learn how it worked. I just assumed there obviously was no filter because I never set one up.

My feeling is that the result window should display a very intuitive and visible sign when the results cannot be taken at face value because of some filters, or, just as well by ANY other issues like permission restrictions that prevented the examinations of some particular sub-folders (like the often-used icon with an exclamation mark in a yellow triangle).

Having to rely in the log for a red line is unpractical because it could be to long to scan by eye without missing anything.

BTW, as far as default filters, IMHO, the only one that (kind of) make sense might be .DS_Store

evolution

2012-08-05 08:26

reporter   ~0000143

I cannot get rid on the default filter. I can delete every line, but it comes back every time.

admin

2012-08-05 08:27

administrator   ~0000144

You are right, but many users asked me to introduce a default set done by versioning files and zip formats.

They convinced me telling "we are developers and rarely need to copy zipped archives".

Now I understand this behavior is really dangerous and I'm considering to prompt a warning dialog informing user that some filter is active.

Please apologize for this bad approach but it was reasonable with a target of users

admin

2012-08-05 08:29

administrator   ~0000145

"I cannot get rid on the default filter. I can delete every line, but it comes back every time. "

Oh I don't understand

1. start diff
2. open filter dialog and remove all or part of filters
3. press ok, diff restarts using new filters (if any)
4. save session (if necessary)

evolution

2012-08-05 09:35

reporter   ~0000146

I understand the audience who asked for filters, but VisualDiffer is, AT LONG LAST, a very usable and great looking app, and precisely for end-users.

Many users might need one or several preset filters, to easily turn ON or OFF a full set at once without typing line by line, but by no means ON by default.
Maybe the app could simply debut with no filters but memorize the last set used, I guess that could satisfy everybody. But please implement the warning! People could loose data with this!

Also, please note my use case:
As an end-user (not to mention a mac-user since the "origin of times" - 1984!), I have tons of hard disks filled with a mess of incomplete data sets, personal data, photos etc... folders originally well-organized, but then duplicated and having extra data added independently for various reasons, different computers, different work places, traveling and taking work folders with me, whatever… I guess everybody does it…

I am in the process of cleaning up years of data…. I cannot just discard a folder without making sure it doesn't have the ONLY copy of some files, so I go through the process of manually reconciling folders from the top down, so when I can find the largest folder structure that is identical to a master copy, without looking at the details inside, then I am very happy knowing I can discard it right away.
I just want to reconcile everything to a master set of data containing hopefully a single copy of everything. So I cannot afford the program omitting any type of files, and ESPECIALLY zip files!
Zip files are very important because in the past, I have often compressed in a hurry a bunch of file and folders in a desperate attempt to make room in a disk that was nearly full (less of an issue nowadays because disks are very large and cheap).

In this context, your app being visual is very valuable to me and also pleasant to use. It is a great tool like no other app I have tried before! DeltaWalker was kind of fine for a while, somewhat visual, but way too technical and quirky for an end-user.

evolution

2012-08-05 09:44

reporter   ~0000147

Last edited: 2012-08-05 10:44

View 2 revisions

[EDIT]My comments below are incorrect: An option to set default filters has been implemented under the "cog wheel" button[/EDIT]

About my comment: "I cannot get rid of the default filter"...

I meant, EVERY time I start the app, or even a new diff in the same work session, I will have to delete the filter manually, over and over.

If I stop using the app for a few months, I may likely forget those filter are in place by default because it is no unintuitive to have them by default. A warning will help me remembering they are there, but will not remove the frustration to have to delete them again and again.

"Preferences" were created just for that, specifying what the user prefer.

admin

2012-08-05 09:49

administrator   ~0000148

About comment 146: I totally agree with you, consider VisualDiffer is young and it fits my needs, now that app is more popular I will embrace any modification to fit the general user needs.

I will change the current behavior and I will alert user about filter in use (if any)



About comment 147: You can set your filter as default

From Filter dialog, click on tool button (near the help button) and select the menu item 'Set Current as Defaults"

evolution

2013-03-15 11:49

reporter   ~0000239

"Resolution open => won't fix " ???? What happened? I am puzzled!

So we went from comment 148 that said: "I totally agree .... I will change the current behavior and I will alert user about filter in use (if any)"

to: "Won't fix" ?????

Seriously?

What is needed a a strong VISUAL indication that files are omitted in a diff results so that the user is clearly informed.
Otherwise, this app doesn't deserve the "Visual" moniker, IMHO.

Note that files could be omitted from results either by a a filter in place OR by lack of permissions to traverse a particular folder.
The WARNING should be VISUAL and PROMINENT - the Toolbar appears like a good location for it

admin

2013-03-15 12:06

administrator   ~0000240

Last edited: 2013-03-15 12:07

View 2 revisions

Starting from v1.5.2 the default filter no longer contains archive files so the warning is not necessary for new users.

Showing the message on previously installation seems me to late, users are already discovered the filter uses archive files

admin

2013-04-12 08:05

administrator   ~0000264

Have you verified on version 1.5.2?

May I close this bug?

evolution

2013-04-12 17:00

reporter   ~0000268

Last edited: 2013-04-12 17:06

View 7 revisions

I confirm fixed in 1.5.2 as described (i.e. .zip, .tar ... kind of files are no longer omitted by default)

However... those particular extensions were only the main problem. Other extensions (which I don't much about) are still omitted by default. The unsuspecting user will naturally think that VisualDiffer is comparing everything, and is not making untold omissions without even a warning in the result window that some files are actually omitted.

The lack of indication that the results are filtered and files actually omitted is probably the main issue here.

I wouldn't see that as a problem is the app was clearly reserved to technically-oriented users, but it is marketed to appeal to novice users whose typical usage is to cleanup their drives, blindly compare folders so they can dump any one of two folders found identical.
By default, VisualDiffer is set to provide them the wrong answer. To get the right answer, they have to be aware of the issue to start with (not obvious), modify the filter and set it as default. That a lot to ask a non-technical user.

This being said, it could be that the particular file extensions set as default have little incidence if it leads to such files deleted by mistake (like DS_Store), I cannot gauge that because I don't know what they are. I mostly say, in general, that there should be a visual indicator when results are filtered.

admin

2013-04-12 17:07

administrator   ~0000270

Consider now only versioning files are omitted, the full list is shown below

"CVS"
".svn"
".git"
".hg"
".bzr"

Plus backup files "*~" and .DS_Store

No other files are automatically excluded

I don't want to break the user experience with prompts and alert messages but I understand your point of view

evolution

2013-04-12 20:17

reporter   ~0000271

Unfortunately, I don't know what those file types are..

True, modal dialogs that require user action to be dismissed are to be avoided.

I didn't think I'd have to mention this, but there ways to display info to the user without prompts or alert dialogs. A simple info line like "Warning: Filter active!" displayed anywhere in the GUI, or coloring the Filter icon in the Toolbar and/or changing its name to "Filter active", are ways to inform the user without bothering him at all, just being informative with no user action required.

My last word... I am still it puzzled to have VisualDiffer, in effect, announce: "Those two folders are identical" when they clearly are not and with no warning whatsoever. However benign one may find it, such a situation should not be acceptable when the end result could be inadvertent data loss.

admin

2013-04-13 10:23

administrator   ~0000272

> Unfortunately, I don't know what those file types are..

Indeed they are very technical files and see them is really really uncommon

> I didn't think I'd have to mention this, but there ways to display info to the user without prompts or alert dialogs. A simple info line like "Warning: Filter active!" displayed anywhere in the GUI, or coloring the Filter icon in the Toolbar and/or changing its name to "Filter active", are ways to inform the user without bothering him at all, just being informative with no user action required.

Toolbar button can be removed by user so it should be not a good solution but talking with you I'm realizing that maybe the scope bar (where there are buttons with "Only Mismatches ... | Filtered Empty Folders") could be used, for example "Filtered (20)".

> My last word... I am still it puzzled to have VisualDiffer, in effect, announce: "Those two folders are identical" when they clearly are not and with no warning whatsoever. However benign one may find it, such a situation should not be acceptable when the end result could be inadvertent data loss.

This is really critical, may you detect where and why VD fail?
I'm pretty sure the result is correct, if I compare the result with other applications (expecially with DeltaWalker and Araxis Merge) I obtain same results (after setting same filter)

Issue History

Date Modified Username Field Change
2012-08-05 06:35 evolution New Issue
2012-08-05 06:35 evolution Status new => assigned
2012-08-05 06:35 evolution Assigned To => admin
2012-08-05 07:44 evolution Note Added: 0000140
2012-08-05 07:44 evolution Note Edited: 0000140 View Revisions
2012-08-05 08:09 admin Note Added: 0000141
2012-08-05 08:22 evolution Note Added: 0000142
2012-08-05 08:26 evolution Note Added: 0000143
2012-08-05 08:27 admin Note Added: 0000144
2012-08-05 08:29 admin Note Added: 0000145
2012-08-05 09:35 evolution Note Added: 0000146
2012-08-05 09:44 evolution Note Added: 0000147
2012-08-05 09:49 admin Note Added: 0000148
2012-08-05 10:44 evolution Note Edited: 0000147 View Revisions
2013-03-15 10:30 admin Status assigned => closed
2013-03-15 10:30 admin Resolution open => won't fix
2013-03-15 11:49 evolution Note Added: 0000239
2013-03-15 11:49 evolution Status closed => feedback
2013-03-15 11:49 evolution Resolution won't fix => reopened
2013-03-15 12:06 admin Note Added: 0000240
2013-03-15 12:07 admin Note Edited: 0000240 View Revisions
2013-04-12 08:05 admin Note Added: 0000264
2013-04-12 17:00 evolution Note Added: 0000268
2013-04-12 17:00 evolution Status feedback => assigned
2013-04-12 17:01 evolution Note Edited: 0000268 View Revisions
2013-04-12 17:01 evolution Note Edited: 0000268 View Revisions
2013-04-12 17:02 evolution Note Edited: 0000268 View Revisions
2013-04-12 17:05 evolution Note Edited: 0000268 View Revisions
2013-04-12 17:06 evolution Note Edited: 0000268 View Revisions
2013-04-12 17:06 evolution Note Edited: 0000268 View Revisions
2013-04-12 17:07 admin Note Added: 0000270
2013-04-12 20:17 evolution Note Added: 0000271
2013-04-13 10:23 admin Note Added: 0000272