View Issue Details

IDProjectCategoryView StatusLast Update
0000124VisualDifferGeneralpublic2013-04-12 08:11
ReporterevolutionAssigned Toadmin 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
PlatformMacOSOS XOS Version10.8
Product Version1.4.3 
Target VersionFixed in Version1.5.2 
Summary0000124: Packages should be differentiated from folders in GUI
DescriptionTechnically, packages are folders, but from a GUI standpoint for the end user, they are meant to be undifferentiated from files. Regular end-users are not meant to look inside, or to even know a package content is granular.

So I suggest 2 things:

1- Some GUI artifacts to differentiate packages from ordinary folders.

2- A way to hide their content. That seems just like a filter, but not readily feasible with existing GUI because we can only filter by file name extensions (as far as I know, a package is not determined by its extension).
If we could somehow filter the content of a package out of view, it would appear just like a file to the user.
Not so simple however, because a filter currently prevents processing as well, and a package content must be processed to determine whether the whole thing is "same" or "different" (using dates would be tricky because it could potentially be a mixture of older an newer).
As far as copying, when in this mode of hiding the content, user could not pick and choose partial content to copy, and that would be fine because compatible with the end-user paradigm: "package = file".
So hiding out package content seems tricky, but some GUI artifact to differentiate would be welcome.
TagsNo tags attached.

Activities

admin

2012-08-05 12:19

administrator   ~0000149

I would study how other apps resolve this problem, I will try to look at pathfinder or trasmit.
Hide the content sounds a bit more complicated but something can be done, I have in version 1.4.6 or 1.4.7 to implement some solution.
Any progress and decision will be posted here

admin

2013-03-16 10:09

administrator   ~0000241

UI doesn't change for packages but now it is possible to skip them from folder traversal

Issue History

Date Modified Username Field Change
2012-08-05 10:38 evolution New Issue
2012-08-05 10:38 evolution Status new => assigned
2012-08-05 10:38 evolution Assigned To => admin
2012-08-05 12:19 admin Note Added: 0000149
2013-03-16 10:09 admin Note Added: 0000241
2013-03-16 10:09 admin Status assigned => resolved
2013-03-16 10:09 admin Fixed in Version => 1.5.2
2013-04-12 08:11 admin Status resolved => closed
2013-04-12 08:11 admin Resolution open => fixed