View Issue Details

IDProjectCategoryView StatusLast Update
0000125VisualDifferGeneralpublic2012-11-09 10:54
ReporterevolutionAssigned Toadmin 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformMacOSOS XOS Version10.8
Product Version1.4.3 
Target VersionFixed in Version1.4.4 
Summary0000125: Date format fails to follow user preference as set in System Preferences
DescriptionThe DATE format seems to be hard-coded, does not follow the user preference as set in System Preferences>Language & Test>Region

For instance, my time format (Short) is set like "25-Jan-12" (in other words "DD-MMM-YY"), but VisualDiffer still displays it as 01/25/12.

This is extremely confusing to me to have the day and month swapped, especially in VisualDisplay where I need to compares dates between left and right panes, and especially with the Month not shown with letters because the format is then intrinsically ambiguous.

Strangely, the TIME format seems to follow the 24-HR format I used, but this might also be hard-coded (luckily just the way I like it)
TagsNo tags attached.

Activities

admin

2012-08-18 11:13

administrator   ~0000155

Date format is hard coded because by default seconds are shown by visualdiffer.

Apple doesn't gives any system predefined date format containing seconds (accessible for developer) so I've hard coded that.

The solution consists to add specific code inside VisualDiffer to allow user to edit the format, this isn't a priority task but it's under my radar

evolution

2012-09-02 02:59

reporter   ~0000156

A few comments:

1- It wouldn't be so bad to have the date hard-coded if you had chosen to represent the Month with 3 letters instead of 2 digits, because it would be non-ambiguous. Couldn't this single change be done on a shorter term horizon?

2- Why not hard-code only the time if seconds are needed, but take the date format from the system?
Beware however that there seems to be a bug in OS X if day and month are swapped while using Region=United States (Apple's calendar is affected, as well as some third party apps; basically the date string is messed up, the day no longer appears and the month is displayed twice - I need to report that bug to Apple when I get some time)

3- If you do offer user preferences within VisualDiffer, please make it FLEXIBLE. Don't just allow the user to select the order D/M/Y, but also allow the month to be shown with 3 letters. This is critical to avoid ambiguity. In fact, it is less important for me to have the right order than to have no ambiguity.
It is also important to be able to format the day with forced two digits, i.e., "01" and not "1".

So please make it flexible enough so users can choose what they want.

admin

2012-09-02 09:33

administrator   ~0000159

Implementing a fully functional UI isn't a priority task but I let users to set their own format using the standard Apple command 'defaults'.

For further details see the wiki (this will available in version 1.4.4)

http://wiki.visualdiffer.com/index.php/Frequently_Asked_Questions#Customize_the_file_date.2Ftime_format_in_Folder_Differ_View

admin

2012-09-02 09:55

administrator   ~0000164

Try

defaults write com.visualdiffer folderViewDateFormat ddMMMYY

to set the format you like

Issue History

Date Modified Username Field Change
2012-08-07 19:48 evolution New Issue
2012-08-07 19:48 evolution Status new => assigned
2012-08-07 19:48 evolution Assigned To => admin
2012-08-18 11:13 admin Note Added: 0000155
2012-09-02 02:59 evolution Note Added: 0000156
2012-09-02 09:33 admin Note Added: 0000159
2012-09-02 09:55 admin Note Added: 0000164
2012-11-09 10:54 admin Status assigned => closed
2012-11-09 10:54 admin Resolution open => fixed
2012-11-09 10:54 admin Fixed in Version => 1.4.4