View Issue Details

IDProjectCategoryView StatusLast Update
0000127VisualDifferGeneralpublic2013-03-15 10:15
ReporterevolutionAssigned Toadmin 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformMacOSOS XOS Version10.8
Product Version1.4.3 
Target VersionFixed in Version1.5.2 
Summary0000127: Always crashes while comparing system folders, in particular folder "JavaVM.framework"
DescriptionVisualDiffer crashes systematically when comparing two System folders (I need to do this to figure out changes after some software installations).

I found this by setting up VisualDiffer as follows:
    Left side: /Volumes/Boot1/System/Library/
    Right side: /Volumes/Boot2/System/Library/

Upon analysis, I found that the crash still occurs when limiting the comparison to:
    Left side: /Volumes/Boot1/System/Library/Frameworks/JavaVM.framework
    Right side: /Volumes/Boot2/System/Library/Frameworks/JavaVM.framework

Notes:
   1- Neither Boot1 nor Boot2 is the current startup disk
   2- This is regular system folder coming from a recent Mountain Lion installation (10.8)
   3- The crash is near instantaneous after hitting "Show Diffs"

The crash also occurs when working from the current startup disk, and setting both sides to the same folder:
    Left side: /System/Library/Frameworks/JavaVM.framework
    Right side: /System/Library/Frameworks/JavaVM.framework
so it should be easy to reproduce the issue.

I wanted to attach a copy of JavaVM.framework folder to this report, so I made several copies of it out of the System folder, but then I found that VisualDiffer does NOT crash when working on those out-of-context folders.

I tried to add ".framework" to the default filter, but no effect

It is worth noting that JavaVM.framework contains hard links, so maybe this issue is linked to issue # 122 that I previously reported
Steps To ReproduceTo reproduce, that should do it:
    Left side: /System/Library/Frameworks/JavaVM.framework
    Right side: /System/Library/Frameworks/JavaVM.framework
TagsNo tags attached.

Activities

evolution

2012-08-17 00:07

reporter   ~0000151

I wish to know of any way-arounds, since I badly need VisualDiffer to compare system folders on my current project.
How could I exclude such problem folders, or maybe just how to exclude aliases/symlinks /hardlinks since I suspect those are causing the issue???

Thanks!

admin

2012-08-18 09:42

administrator   ~0000152

I'm investigating the crash that I've reproduced on my 10.8 machine

It is not possible to exclude aliases/symlinks/hardlinks, this is a major bug that must be fixed.

admin

2012-08-18 10:40

administrator   ~0000154

Ok found the problem, the *infinite* recursive calls end with app crash

I've fixed simply stopping traversing symlinks, they appear as empty folders and the badge icon is shown to communicate to user it is a symlink.

If you want I can send you the fixed version so you can test if it fits your needs.

evolution

2012-09-02 03:25

reporter   ~0000158

Yes please, I'd like to have the fixed version. Do you have access to my email as set in my account here?

I will probably need to use it in a few day (I actually stopped using it because of that bug, it was in constant trouble).

admin

2012-09-02 09:40

administrator   ~0000160

No need to know you email, I'll attach the file to this bug,

evolution

2012-09-02 09:47

reporter   ~0000162

Thanks, but sorry, I don't know where the file for the fixed version is. Or did you not post it yet?

admin

2012-09-02 09:53

administrator   ~0000163

My internet connection is very slow, now you should see the file.

PLEASE Note the copy doesn't is fully functional, this is an alpha. The symlinks folders are copied as empty folders

evolution

2012-09-02 11:34

reporter   ~0000168

Yes, I got it now. Thanks a lot. Will try later...

Is it normal to bear the same version number as what I updated from the Mac App Store, i.e., 1.4.3?

admin

2012-09-02 11:36

administrator   ~0000169

yes, it is normal and MAS version and this one can run side by side

please remember copy doesn't work at all

evolution

2012-09-02 11:50

reporter   ~0000170

Copy doesn't work at all? or is it just that Symlinks not being followed?
 
If the latter, then it would just be the perfect way I expect it to work (see my comment 166).

I understand it is alpha, but I am surprised to see a symlink transformed into a folder (even if a symlink to a file?).
Isn't a symlink just a simple file to start with? I have copied symlinks many times using Finder or Terminal, and they remain symlink files (although I know with Terminal, you can add parameters to follow links, one step or recursively)

Issue History

Date Modified Username Field Change
2012-08-16 23:58 evolution New Issue
2012-08-16 23:58 evolution Status new => assigned
2012-08-16 23:58 evolution Assigned To => admin
2012-08-17 00:07 evolution Note Added: 0000151
2012-08-18 09:42 admin Note Added: 0000152
2012-08-18 09:42 admin Priority normal => urgent
2012-08-18 10:40 admin Note Added: 0000154
2012-09-02 03:25 evolution Note Added: 0000158
2012-09-02 09:40 admin Note Added: 0000160
2012-09-02 09:47 evolution Note Added: 0000162
2012-09-02 09:51 admin File Added: VisualDiffer.app.zip
2012-09-02 09:53 admin Note Added: 0000163
2012-09-02 11:34 evolution Note Added: 0000168
2012-09-02 11:36 admin Note Added: 0000169
2012-09-02 11:50 evolution Note Added: 0000170
2013-03-15 10:15 admin Status assigned => closed
2013-03-15 10:15 admin Resolution open => fixed
2013-03-15 10:15 admin Fixed in Version => 1.5.2
2013-04-13 11:08 admin File Deleted: VisualDiffer.app.zip