View Issue Details

IDProjectCategoryView StatusLast Update
0000133VisualDifferGeneralpublic2013-01-27 11:24
ReporterwayneljwAssigned Toadmin 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformMacOSOS XOS Version10.8.2
Product Version1.4.3 
Target VersionFixed in Version1.5.1 
Summary0000133: Visdiff shell command no longer work: Does not work with Dreamweaver any more after upgrading to 1.4.4
DescriptionThe similar issue happens again after upgrading to 1.4.4. Please see bug id 0000116.

It works well with 1.4.3

The symptom is different to bug id 0000116 though.

This time, it doesn't show any error message (after I use the "Compare" function from Dreamweaver). It simply shows a VisualDiffer window without any comparison result. (in other words, the window appears as if I opened VisualDiffer from the Application Folder)
Steps To Reproducein Dreamweaver, right click on a file and select "compare with remote".

In version 1.4.3: files can be successfully compared. (provided we setup the working folder as trusted for app sandbox)

in version 1.4.4: it simply shows a VisualDiffer window without comparison contents.
Additional InformationI have setup my working folder as trusted
TagsNo tags attached.

Activities

admin

2012-11-08 20:28

administrator   ~0000178

Last edited: 2012-11-08 20:31

View 2 revisions

Please open console.app than run VisualDiffer and check if console contains some message relative to VisualDiffer

wayneljw

2012-11-09 05:53

reporter  

Console.png (28,988 bytes)
Console.png (28,988 bytes)

wayneljw

2012-11-09 05:54

reporter  

FullReport.txt (4,252 bytes)
visdiff(7716) deny mach-lookup com.visualdiffer.VisualDiffer

Process:         visdiff [7716]
Path:            /Applications/VisualDiffer.app/Contents/Resources/visdiff
Load Address:    0x100000000
Identifier:      visdiff
Version:         ??? (???)
Code Type:       x86_64 (Native)
Parent Process:  Dreamweaver [6188]

Date/Time:       2012-11-09 12:49:25.388 +0800
OS Version:      Mac OS X 10.8.2 (12C60)
Report Version:  8

Thread 0:
0   libsystem_kernel.dylib        	0x00007fff950d6686 mach_msg_trap + 10
1   liblaunch.dylib               	0x00007fff9189e7c4
2   liblaunch.dylib               	0x00007fff9189d4d9 bootstrap_look_up3 + 69
3   liblaunch.dylib               	0x00007fff9189d609 bootstrap_look_up2 + 40
4   Foundation                    	0x00007fff96545dce -[NSMachBootstrapServer portForName:options:] + 102
5   Foundation                    	0x00007fff9655129b +[NSConnection connectionWithRegisteredName:host:usingNameServer:] + 30
6   Foundation                    	0x00007fff964bffd0 +[NSConnection rootProxyForConnectionWithRegisteredName:host:] + 64
7   visdiff                       	0x0000000100002795
8   visdiff                       	0x000000010000284c
9   visdiff                       	0x0000000100002bd5
10  visdiff                       	0x0000000100001c6c

Thread 1:
0   libsystem_kernel.dylib        	0x00007fff950d8d16 kevent + 10
1   libdispatch.dylib             	0x00007fff96a939ee _dispatch_mgr_thread + 54

Thread 2:
0   libsystem_kernel.dylib        	0x00007fff950d86d6 __workq_kernreturn + 10
1   libdispatch.dylib             	0x00007fff96a92073 _dispatch_queue_wakeup_global_slow + 59
2   libdispatch.dylib             	0x00007fff96a91ecd _dispatch_wakeup + 132
3   libdispatch.dylib             	0x00007fff96a91e10 _dispatch_queue_push_list_slow2 + 33
4   libxpc.dylib                  	0x00007fff8f6d3038 xpc_connection_send_message + 77
5   CoreFoundation                	0x00007fff9698bef3 -[_NSDNXPCConnection sendMessage:waitForSend:] + 163
6   CoreFoundation                	0x00007fff9685ef2d _CFXNotificationRegisterObserver + 1261
7   CoreFoundation                	0x00007fff9691671b __block_global_2 + 507
8   libdispatch.dylib             	0x00007fff96a94f01 _dispatch_call_block_and_release + 15
9   libdispatch.dylib             	0x00007fff96a910b6 _dispatch_client_callout + 8
10  libdispatch.dylib             	0x00007fff96a9596f _dispatch_after_timer_callback + 22
11  libdispatch.dylib             	0x00007fff96a910b6 _dispatch_client_callout + 8
12  libdispatch.dylib             	0x00007fff96a9329b _dispatch_source_invoke + 691
13  libdispatch.dylib             	0x00007fff96a92305 _dispatch_queue_invoke + 72
14  libdispatch.dylib             	0x00007fff96a921c3 _dispatch_worker_thread2 + 249
15  libsystem_c.dylib             	0x00007fff978fecab _pthread_wqthread + 404
16  libsystem_c.dylib             	0x00007fff978e9171 start_wqthread + 13

Thread 3:
0   libsystem_c.dylib             	0x00007fff978e9164 start_wqthread + 0

Binary Images:
       0x100000000 -        0x100004ff7  visdiff <16F596C1-4DB1-35A0-B673-6F7A864E84BF> /Applications/VisualDiffer.app/Contents/Resources/visdiff
    0x7fff8f6ca000 -     0x7fff8f6ecff7  libxpc.dylib (140.41) <FAC04D8B-680E-325F-8F0C-DD69859D0E01> /usr/lib/system/libxpc.dylib
    0x7fff9189b000 -     0x7fff918a3fff  liblaunch.dylib (442.26.2) <2F71CAF8-6524-329E-AC56-C506658B4C0C> /usr/lib/system/liblaunch.dylib
    0x7fff950c6000 -     0x7fff950e1ff7  libsystem_kernel.dylib (2050.18.24) <C0535565-35D1-31A7-A744-63D9F10F12A4> /usr/lib/system/libsystem_kernel.dylib
    0x7fff9649c000 -     0x7fff967f8fff  com.apple.Foundation (6.8 - 945.11) <A5D41956-A354-3ACC-9355-BE200072223B> /System/Library/Frameworks/Foundation.framework/Versions/C/Foundation
    0x7fff96828000 -     0x7fff96a11fff  com.apple.CoreFoundation (6.8 - 744.12) <EF002794-DAEF-31C6-866C-E3E3AC387A9F> /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation
    0x7fff96a8f000 -     0x7fff96aa4ff7  libdispatch.dylib (228.23) <D26996BF-FC57-39EB-8829-F63585561E09> /usr/lib/system/libdispatch.dylib
    0x7fff978e8000 -     0x7fff979b4fe7  libsystem_c.dylib (825.25) <8CBCF9B9-EBB7-365E-A3FF-2F3850763C6B> /usr/lib/system/libsystem_c.dylib
FullReport.txt (4,252 bytes)

wayneljw

2012-11-09 05:55

reporter   ~0000179

Dear Admin,

I have uploaded the console screenshot and the "Full Report" contents.
These logs were generated when I attempted to "compare file" using Dreamweaver.

Thanks

admin

2012-11-09 06:39

administrator   ~0000180

Starting since v1.4.4 Apple required to put in sandbox also command line tools (ie visdiff) but something goes wrong.

Please use the visdiff in attach (it is the version present in v1.4.3 distribution), you can unzip it where you prefer and change into Dreamweaver the path to original one distributed with VisualDiffer.

Please apologize me for inconvenient but believe me sandbox is a hell!!

http://bugs.visualdiffer.com/file_download.php?file_id=24&type=bug

wayneljw

2012-11-09 06:52

reporter   ~0000181

Thanks for the file. I can confirm it works.
And yes, you are right, I know sandbox is a hell!!
No need to say sorry. You are doing good jobs!
Looking forward to v1.4.5

Good Luck and have a nice day!

admin

2012-11-09 07:27

administrator   ~0000182

My pleasure :)

wayneljw

2012-12-15 10:43

reporter   ~0000193

Just upgraded to v1.5 and confirm this problem still exists.
Using the file you provided earlier "visdiff_1_4_3.zip" does solve the problem, though.

thanks

admin

2012-12-15 10:48

administrator   ~0000194

Yes, please apologize me. I've a bug filed at Apple Developer Technical Support.
I've open the bug 2 months ago but at this time I haven't yet a valid reply from Apple team, this is a problem related to sandbox and IPC communication.

I've preferred to publish v1.5 with broken visdiff instead of delay 1.5 release or removing vdiff from standard installation.

This bug is yet open because the problem persists

thanks for your patience and feedback

Issue History

Date Modified Username Field Change
2012-11-08 19:48 wayneljw New Issue
2012-11-08 19:48 wayneljw Status new => assigned
2012-11-08 19:48 wayneljw Assigned To => admin
2012-11-08 20:28 admin Note Added: 0000178
2012-11-08 20:31 admin Note Edited: 0000178 View Revisions
2012-11-09 05:53 wayneljw File Added: Console.png
2012-11-09 05:54 wayneljw File Added: FullReport.txt
2012-11-09 05:55 wayneljw Note Added: 0000179
2012-11-09 06:36 admin File Added: visdiff_1_4_3.zip
2012-11-09 06:39 admin Note Added: 0000180
2012-11-09 06:52 wayneljw Note Added: 0000181
2012-11-09 07:27 admin Note Added: 0000182
2012-11-20 13:49 admin Summary Does not work with Dreamweaver any more after upgrading to 1.4.4 => Visdiff shell command no longer work: Does not work with Dreamweaver any more after upgrading to 1.4.4
2012-12-15 10:43 wayneljw Note Added: 0000193
2012-12-15 10:48 admin Note Added: 0000194
2013-01-19 12:29 admin Status assigned => resolved
2013-01-19 12:29 admin Resolution open => fixed
2013-01-19 12:29 admin Fixed in Version => 1.5.1
2013-01-27 11:24 admin Status resolved => closed
2013-09-01 10:32 admin File Deleted: visdiff_1_4_3.zip