View Issue Details

IDProjectCategoryView StatusLast Update
0000134VisualDifferGeneralpublic2013-03-15 10:28
ReporteralexkliAssigned Toadmin 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformMacOSOS XOS Version10.8.2
Product Version1.4.4 
Target VersionFixed in Version1.5.2 
Summary0000134: visdiff does not work anymore, paths not recognized
DescriptionWith files I get "doesn't exist" on the cli:

====================
$ ls
a b

$ visdiff a b
Left path doesn't exist
Right path doesn't exist
====================

When specifying folders:
- I get same "path doesn't exist" when using relative paths
  $ visdiff folder1 folder2
- when using absolute paths, VisualDiffer app opens, but shows empty "Compare Folders or Files" dialog
  $ visdiff `pwd`/folder1 `pwd`/folder2
TagsNo tags attached.

Activities

alexkli

2012-11-20 13:49

reporter   ~0000183

I also set a common base path as "Trusted path" in the settings, but to no avail.

admin

2012-11-20 13:52

administrator   ~0000184

Last edited: 2012-11-20 13:53

View 2 revisions

Please apologize for inconvenient but the sandbox mechanics has broken the command line tool.

You can download the visdiff not sandboxed from here

http://bugs.visualdiffer.com/file_download.php?file_id=24&type=bug

You can read the full bug at http://bugs.visualdiffer.com/view.php?id=133

Please let me know if this workaround fits your needs

I'm working together with Apple team to fix problem with sandboxed command line tools

alexkli

2012-11-20 14:28

reporter   ~0000185

Thanks, with the above version of visdiff it worked (had to restart my shell, though).

However, even if it automatically saves the opened paths as "trusted paths", it sill asks me with the dialog "file not accessible" every single time. But maybe another sandbox issue ;-)

admin

2012-11-20 14:37

administrator   ~0000186

I'm sure it is related to sandbox, may you describe me step by step how to reproduce the "file not accessible" bug?

I'm unable to reproduce it on my env.

alexkli

2012-11-21 15:11

reporter   ~0000187

Well, now I can't reproduce it anymore! Maybe it was an issue with an old shell still open, just as I had to open a new shell to get the modified visdiff cli binary to work.

I now added "/" to the trusted paths and together with the visdiff 1.2 binary it works great :-)

For reference, here are the steps that failed before and now work:
- on the cli:
$ echo "foo" > a
$ echo "bar" > b
$ visdiff a b
- VisualDiffer opens
- shows me the file dialog titled "Left File Not Accessible", with the parent folder of "a" already selected
- select file "a" and click "Open"
- shows me the file dialog titled "Right File Not Accessible", with the parent folder of "b" already selected
- select file "b" and click "Open"
- diff of a and b is properly shown
- check "Trusted paths" preferences: absolute paths to "a" and "b" are automatically added
- quit visual differ
$ visdiff a b
=> VisualDiffer opens and shows diff right away (or showed file dialogs once again)

admin

2012-11-21 15:17

administrator   ~0000188

> I now added "/" to the trusted paths and together with the visdiff 1.2 binary it works great

This sounds like using a thermo nuclear bomb :D but fighting against sandbox requires nuclear weapons

I will try to reproduce using your test case.

I've found a regression on passing relative paths, when sandboxed relative paths are not recognized, I've fixed this bug and it will be available in next version.

Issue History

Date Modified Username Field Change
2012-11-20 13:46 alexkli New Issue
2012-11-20 13:46 alexkli Status new => assigned
2012-11-20 13:46 alexkli Assigned To => admin
2012-11-20 13:49 alexkli Note Added: 0000183
2012-11-20 13:52 admin Note Added: 0000184
2012-11-20 13:53 admin Note Edited: 0000184 View Revisions
2012-11-20 14:28 alexkli Note Added: 0000185
2012-11-20 14:37 admin Note Added: 0000186
2012-11-21 15:11 alexkli Note Added: 0000187
2012-11-21 15:17 admin Note Added: 0000188
2013-03-15 10:28 admin Status assigned => closed
2013-03-15 10:28 admin Resolution open => fixed
2013-03-15 10:28 admin Fixed in Version => 1.5.2