View Issue Details

IDProjectCategoryView StatusLast Update
0000145VisualDifferGeneralpublic2013-01-27 11:24
Reporterbrent_knightAssigned Toadmin 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformMac OS X 10.8.2OSMac OS X 10.8.2OS VersionMac OS X 10.8.2
Product Version1.5 
Target VersionFixed in Version1.5.1 
Summary0000145: Rejects a path to the root of a volume; especially severe with visdiff (cli exe)
DescriptionI have some disk images that I try to keep in sync.
When I try to compare them using VisualDiffer, it always complains that there is no such path.
In the GUI, it will let me choose it again and then it will work (didn't try this today, though).

But when using the "visdiff" cli tool, it fails and cannot be made to work:


% visdiff --wait /Volumes/100mb '/Volumes/100mb 1'
Left path doesn't exist


% visdiff --wait /Volumes/100mb/ '/Volumes/100mb 1/'
Left path doesn't exist


% visdiff --wait /Volumes/100mb/. '/Volumes/100mb 1/.'
Left path doesn't exist
Steps To ReproduceSteps:

1. create a couple of 100mb disk images using Disk Utility (or hdiutil) if necessary

2. mount them (may already be mounted if created with Disk Utility)

3. % visdiff /Volumes/My_Volume_Mounted_From_Disk_Image_#1 /Volumes/My_Volume_Mounted_From_Disk_Image_#2

4. unexpected error from cli and GUI doesn't do anything: "Left path doesn't exist"
TagsNo tags attached.

Activities

admin

2013-01-04 08:17

administrator   ~0000205

> In the GUI, it will let me choose it again and then it will work (didn't try this today, though).

This seems related to trusted paths and OSX sandbox (you can check them from VisualDiffer preferences panel).
I've tested on my env but everything works, below I describe what I did

1. open (ie mount) from Finder DMG file 1
2. open (ie mount) from Finder DMG file 2
3. from VisualDiffer select /Volume/DMG1
4. from VisualDiffer select /Volume/DMG2
5. start comparison
6. save VisualDiffer session file
7. close VisualDiffer
8. Run again VisualDiffer and open saved session

Please if you do something different tell me in detail so I can reproduce myself

> But when using the "visdiff" cli tool, it fails and cannot be made to work:

The problem with visdiff cli is known and is due to OSX sandbox, I've open a file to apple and I'm waiting a solution, the temporary workaround consists to use the visdiff version distributed with VisualDiffer 1.4.3

You can refer to wiki to download the correct file
http://wiki.visualdiffer.com/index.php/Frequently_Asked_Questions#visdiff_command_line_tool_no_longer_works

Issue History

Date Modified Username Field Change
2013-01-03 21:59 brent_knight New Issue
2013-01-03 21:59 brent_knight Status new => assigned
2013-01-03 21:59 brent_knight Assigned To => admin
2013-01-04 08:17 admin Note Added: 0000205
2013-01-19 12:28 admin Status assigned => resolved
2013-01-19 12:28 admin Resolution open => fixed
2013-01-19 12:28 admin Fixed in Version => 1.5.1
2013-01-19 12:28 admin Description Updated View Revisions
2013-01-27 11:24 admin Status resolved => closed