View Issue Details

IDProjectCategoryView StatusLast Update
0000151VisualDifferFolders differpublic2013-03-15 10:13
ReporterTobiasAssigned Toadmin 
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Product Version1.5.1 
Target VersionFixed in Version1.5.2 
Summary0000151: Button to expand only one side
DescriptionOften I'm dealing with a few folders on the left and a huge archive on the right, to which I want to add new files. It'd be nice if "Expand All" could be restricted to one side.
TagsNo tags attached.

Activities

admin

2013-02-25 16:30

administrator   ~0000223

Have you tried to select only folders to expand and from context menu select 'Expand all subfolders'?

Tobias

2013-02-25 16:36

reporter   ~0000224

It's more effort but works

It'd help if "Select All" didn't also select hidden folders (I'm using "Only Mismatches")

admin

2013-02-25 16:42

administrator   ~0000225

Do you mean filtered folders (green colored)?

Tobias

2013-02-25 18:51

reporter   ~0000226

(they're purple, but forget that I said hidden)

If I select a folder and "expand all sub" from its context menu, the expected thing happens.

If I right-click an empty area, that is a folder that only exists on one side, the context menu is empty.

But if I use cmd+a to select all, and expand from the context menu, not only the folders in the selection expand, but also those only on the other side, corresponding to the selected empty rows.

admin

2013-02-25 19:04

administrator   ~0000227

Ok now it's clear.

> But if I use cmd+a to select all, and expand from the context menu, not only the folders in the selection expand, but also those only on the other side, corresponding to the selected empty rows.

This is by design but I understand your needs, maybe I can add an alternate menu (shown when you hold down the ALT key) so ''Expand all subfolders' becomes ''Expand only existing subfolders'

Issue History

Date Modified Username Field Change
2013-02-25 16:27 Tobias New Issue
2013-02-25 16:27 Tobias Status new => assigned
2013-02-25 16:27 Tobias Assigned To => admin
2013-02-25 16:30 admin Note Added: 0000223
2013-02-25 16:36 Tobias Note Added: 0000224
2013-02-25 16:42 admin Note Added: 0000225
2013-02-25 18:51 Tobias Note Added: 0000226
2013-02-25 19:04 admin Note Added: 0000227
2013-03-15 10:13 admin Status assigned => closed
2013-03-15 10:13 admin Resolution open => fixed
2013-03-15 10:13 admin Fixed in Version => 1.5.2