View Issue Details

IDProjectCategoryView StatusLast Update
0000162VisualDifferFiles differpublic2013-09-12 17:05
ReportertkmantisAssigned Toadmin 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformMacintoshOSOS XOS Version10.6.8
Product Version1.5.1 
Target VersionFixed in Version1.5.6 
Summary0000162: When comparing files, need check resource fork also
DescriptionWhen comparing files, the app needs to consider the resource fork as well as the data fork. When comparing files by size, need to consider the size of the resource fork and the size of the data fork, and if either is different, file is different. When comparing content, need to do the byte-by-byte binary comparison on both data and resource forks.
Steps To ReproducePerform test comparison where you set up two trees that contain files that are alike in data fork, but different in resource fork.
TagsNo tags attached.

Relationships

related to 0000195 closedadmin Not recognizing the difference between files that have had their resource forks stripped. 
related to 0000163 closedadmin Folder size totals are often incorrect (Resource Forks) 

Activities

admin

2013-04-08 09:01

administrator   ~0000252

I admit the resource fork is a totally unexplored land on VisualDiffer.

May you point me on some example so I can create a test case?

tkmantis

2013-04-08 15:25

reporter   ~0000255

Get this free app and you can alter bytes of data and resource forks and even create resource forks.

http://www.macupdate.com/app/mac/17562/hexedit

admin

2013-04-12 08:07

administrator   ~0000266

HexHedit hosted at sourceforge is a very old application, I've found only the source code but it doesn't compile on current XCode version

tkmantis

2013-04-13 12:11

reporter   ~0000273

You can download the binary .dmg for hexedit from the "Download Now" link on that MacUpdate page I linked above.

tkmantis

2013-07-04 04:49

reporter   ~0000297

Last edited: 2013-07-04 04:49

View 2 revisions

What is the status on this? Is this going to be fixed?

admin

2013-07-04 08:09

administrator   ~0000304

I've written the code but the implementation (it's a complicated way to test if an 'object' is a resource fork) is very very slow because every file must be checked, so I've decided to not include, at this time, in production code.

tkmantis

2013-07-05 06:08

reporter   ~0000306

Perhaps the resource fork comparison should be an option with a check box, as in

[ ] Compare Resource Forks (slow)

tkmantis

2013-07-28 06:38

reporter   ~0000324

Any more progress on this one?

admin

2013-07-28 08:12

administrator   ~0000325

I've dedicated few days to this bug but the implementation is really slow and VD crashes too much, so I moved this bug to the low priority queue (very low)

admin

2013-08-31 16:36

administrator   ~0000365

Hi,

great news.
The resource fork feature has landed on the alpha version (it is a checkbox present in session preference)

I don't work with resforks so I need a deeper test, do you want to test the alpha version?

I can send to you it

Thanks for your support

tkmantis

2013-09-02 07:38

reporter   ~0000366

Thank you. Yes, please do send it to me for test.

admin

2013-09-02 17:59

administrator   ~0000367

Last edited: 2013-09-05 17:01

View 2 revisions

Ok, here the zipped version http://cl.ly/0L3M0S1r1r3P

1. Unzip where you want but don't overwrite the MAS version
2. This version uses a new .vdiff file format, existing sessions will be upgraded
3. If you decide to upgrade existing sessions they never will work with MAS version so please don't use this alpha version to save sessions
4. Resource fork check is disabled by default, you must change it from the session preference under Comparison tab

For every problem you encounter I'm here

Thanks for your patience and support

Issue History

Date Modified Username Field Change
2013-04-07 20:15 tkmantis New Issue
2013-04-07 20:15 tkmantis Status new => assigned
2013-04-07 20:15 tkmantis Assigned To => admin
2013-04-08 09:01 admin Note Added: 0000252
2013-04-08 09:01 admin Status assigned => confirmed
2013-04-08 15:25 tkmantis Note Added: 0000255
2013-04-12 08:07 admin Note Added: 0000266
2013-04-12 08:08 admin Status confirmed => acknowledged
2013-04-13 12:11 tkmantis Note Added: 0000273
2013-07-04 04:49 tkmantis Note Added: 0000297
2013-07-04 04:49 tkmantis Note Edited: 0000297 View Revisions
2013-07-04 08:09 admin Note Added: 0000304
2013-07-05 06:08 tkmantis Note Added: 0000306
2013-07-28 06:38 tkmantis Note Added: 0000324
2013-07-28 08:12 admin Note Added: 0000325
2013-08-30 15:47 admin Relationship added related to 0000195
2013-08-31 16:36 admin Note Added: 0000365
2013-09-01 15:35 admin Relationship added related to 0000163
2013-09-02 07:38 tkmantis Note Added: 0000366
2013-09-02 17:59 admin Note Added: 0000367
2013-09-05 17:01 admin Note Edited: 0000367 View Revisions
2013-09-12 17:05 admin Status acknowledged => closed
2013-09-12 17:05 admin Resolution open => fixed
2013-09-12 17:05 admin Fixed in Version => 1.5.6