View Issue Details

IDProjectCategoryView StatusLast Update
0000187VisualDifferFiles differpublic2013-07-22 19:08
ReportersampleAssigned Toadmin 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformMacOSXOS VersionMountain Lion
Product Version1.5.4 
Target Version1.5.5Fixed in Version1.5.5 
Summary0000187: German umlaut in file name not recognized as same file
DescriptionMaybe this issue is already known. All file names containing a german umlaut like ä, ö etc. lead to detection of two different files although they are identical. This is true for files and folders. VisualDiffer will not recognize them as equal and they appear in separate lines. This happens in all comparison modes.
I would appreciate a solution for this issue. Thank you
TagsNo tags attached.

Activities

admin

2013-07-20 14:22

administrator   ~0000313

I know this bug but I'm unable to reproduce, as you can see on the screenshot on my env everything works fine http://cl.ly/image/1c1b33241P09

Please may you attach to this bug a zip with left and right files and a screenshot?
The files can be empty or with only a couple of character (just a string "hello") but I need the file names to try to reproduce the problem

thanks for your feedback

sample

2013-07-20 16:12

reporter  

miss.png (92,814 bytes)
miss.png (92,814 bytes)

sample

2013-07-20 16:16

reporter   ~0000314

Last edited: 2013-07-20 16:17

View 2 revisions

Thank you for your reply. I could not reproduce the problem with newly generated files on the same disc either. I tried with several usb sticks and different file systems. This seems to be the problem: With equal file systems the characters are well recognized. The windows formats NTFS and exFAT seem to use different character recogntions. The error only occurs when comparing HFS or HFS+ to those file systems. So its not a VisualDiffer bug after all :-)

admin

2013-07-20 17:50

administrator   ~0000315

If I send you a modified version on VisualDiffer may you check it?

Actually I use the same API used by Finder to compare strings but I would check if using a normal localized API the bug can be fixed

sample

2013-07-20 17:58

reporter   ~0000316

Sure.

admin

2013-07-20 18:15

administrator   ~0000317

Ok thanks for your time.

The zip file http://bugs.visualdiffer.com/file_download.php?file_id=32&type=bug contains inside it two other zips, they use two different way to compare string.

The diacritic version is not really appropriated because is case insensitive and I don't want that but documentation says "ignores diacritics (o-umlaut == o)" so I'm curious about result.

- VisualDiffer-localizedCompare.zip
- VisualDiffer-diacritic.zip

How to test:

You don't need to uninstall the MAS version, unzip the file is some other directory (for example creating a directory on your home) and then run your comparison test.

Start using VisualDiffer-localizedCompare because I hope it fixes the problem.

Thanks again

sample

2013-07-21 12:38

reporter   ~0000318

Fantastic. Both of the versions recognize the files as same on different file systems. I still can reproduce the mismatch with the release version afterwords. The diacritic version also does the job with the ü umlaut.
It also works with file names that have just a umlaut and no suffix. Hope to find this in the next release :-)
Let me know if you need me to test anything else.

admin

2013-07-21 13:03

administrator   ~0000319

Last edited: 2013-07-21 13:04

View 2 revisions

Oh great!!!

The diacritic version can't be used because it works only in ignore case mode and this is not what I want but the 'localizedCompare' version can safety replace the current (bugged) code.

I will release a new version very soon with the 'localizedCompare' code so stay tuned :)

You can't imagine how I'm happy to finally be able to fix this known bug, I've tried to replicate formatting disk in HFS, exFat, NTFS and comparing all the combinations without success, I've set my env in german another time without success.

Thank you very much for your help

Issue History

Date Modified Username Field Change
2013-07-20 14:12 sample New Issue
2013-07-20 14:12 sample Status new => assigned
2013-07-20 14:12 sample Assigned To => admin
2013-07-20 14:22 admin Note Added: 0000313
2013-07-20 16:12 sample File Added: miss.png
2013-07-20 16:16 sample Note Added: 0000314
2013-07-20 16:17 sample Note Edited: 0000314 View Revisions
2013-07-20 17:50 admin Note Added: 0000315
2013-07-20 17:58 sample Note Added: 0000316
2013-07-20 18:08 admin File Added: VisualDiffer-CompareFileName.zip
2013-07-20 18:15 admin Note Added: 0000317
2013-07-21 12:38 sample Note Added: 0000318
2013-07-21 13:03 admin Note Added: 0000319
2013-07-21 13:04 admin Note Edited: 0000319 View Revisions
2013-07-22 19:08 admin Status assigned => closed
2013-07-22 19:08 admin Resolution open => fixed
2013-07-22 19:08 admin Fixed in Version => 1.5.5
2013-07-22 19:08 admin Target Version => 1.5.5
2013-09-01 10:30 admin File Deleted: VisualDiffer-CompareFileName.zip