View Issue Details

IDProjectCategoryView StatusLast Update
0000190VisualDifferGeneralpublic2014-02-23 09:28
ReportermatthewadamsAssigned Toadmin 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformIntelOSMac OS XOS Version10.8.4
Product Version1.5.5 
Target VersionFixed in Version1.5.9 
Summary0000190: Allow Esc key to be used to exit application
DescriptionThe only way to quit the application via the keyboard is Cmd+Q. Allow the user to define Esc to be used as an equivalent command to quit the application. Other diff tools do this.

If you want to prompt the user to confirm before quitting, that's fine, but please make sure you include a checkbox allowing me to always skip the prompt.
Steps To ReproduceTry to quit via Esc. App doesn't quit.
TagsNo tags attached.

Activities

admin

2013-08-14 18:31

administrator   ~0000329

Last edited: 2013-08-14 18:32

View 2 revisions

Hitting ESC to quit application isn't a Mac like behavior.
At this time ESC key is used to stop folder reading, asking confirmation if its confirmation is on from Preference dialog.

Consider exiting application is different from closing current window document, I think should be more appropriate hit ESC to close current window document (with or without confirmation dialog) not whole application or quit if the current window is the last document open.

May you tell me which other software (multi document based) on Mac land uses ESC to quit application?

matthewadams

2014-01-15 17:11

reporter   ~0000449

Most applications on most platforms don't use ESC to quit the application, but BeyondCompare on Windows offers that feature.

Why don't you make it an option that the user can select? Developers, as opposed to the general public, would find it extremely convenient.

admin

2014-01-16 09:28

administrator   ~0000455

I totally understand your reasons but under Windows the ESC key is considered the right way to "close" apps, under OSX UI guidelines are different.

Adding it as preferences is fine but I would try to maintain the preference panel clean.

matthewadams

2014-01-16 12:59

reporter   ~0000456

Under Windows, the ESC key is NOT the "right" way; it's Alt+F4. BeyondCompare does it as a convenience.

I don't understand from your response whether you're going to add it. I also don't understand your comment about keeping the preferences panel clean.

Please add it as a user preference.

admin

2014-01-16 16:22

administrator   ~0000459

I want to add it but in version 1.5.9 (version 1.5.8 is closer to be released).

About pref panel, I would a pref panel without to many fine grained prefs because too many prefs in many cases confuse users.

Honestly I don't remember how BC works so I will implement the "Use ESC key to quit application" feature as described below, if you don't agree tell me :)

- ESC will work exactly like CMD+Q, asking to save if necessary/applicable
- If some dialog is open and it responds to ESC (for example input dialogs) the ESC will close the dialog
- Operations in progress (eg folders reading) can be stopped only clicking on stop icon (actually pressing ESC stops the operation)

matthewadams

2014-01-16 17:09

reporter   ~0000460

Sounds good. The only thing to make sure of is that you don't quit the application if you're viewing a file diff view that came from a folder diff view. In that case, an ESC should only close the file diff view and return you to the folder diff view.

What's the ETA on this feature? IOW, when's 1.5.9 expected to be released?

Thanks! :)

admin

2014-01-16 17:43

administrator   ~0000462

Honestly no ETA for 1.5.9, I hope to release 1.5.8 before end of this month and if everything goes right 1.5.9 after 15 february

admin

2014-01-19 11:23

administrator   ~0000468

I think to simplify the design

- if user presses ESC and the current window is the last open then quit app otherwise close the current window

What do you think?

matthewadams

2014-01-19 15:42

reporter   ~0000469

That sounds fine.

Issue History

Date Modified Username Field Change
2013-08-14 18:23 matthewadams New Issue
2013-08-14 18:23 matthewadams Status new => assigned
2013-08-14 18:23 matthewadams Assigned To => admin
2013-08-14 18:31 admin Note Added: 0000329
2013-08-14 18:32 admin Note Edited: 0000329 View Revisions
2014-01-15 17:11 matthewadams Note Added: 0000449
2014-01-16 09:28 admin Note Added: 0000455
2014-01-16 12:59 matthewadams Note Added: 0000456
2014-01-16 16:22 admin Note Added: 0000459
2014-01-16 17:09 matthewadams Note Added: 0000460
2014-01-16 17:43 admin Note Added: 0000462
2014-01-16 18:14 admin Status assigned => acknowledged
2014-01-19 11:23 admin Note Added: 0000468
2014-01-19 15:42 matthewadams Note Added: 0000469
2014-02-23 09:28 admin Status acknowledged => closed
2014-02-23 09:28 admin Resolution open => fixed
2014-02-23 09:28 admin Fixed in Version => 1.5.9