View Issue Details

IDProjectCategoryView StatusLast Update
0000193VisualDifferGeneralpublic2013-09-12 17:09
Reporterphilip_petevAssigned Toadmin 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformOSOS X Mountain LionOS Version10.8.4
Product Version1.5.5 
Target VersionFixed in Version1.5.6 
Summary0000193: Can't save the file in the right panel
DescriptionWhen I open the program and select the first and the second file:

1. From the dropdown menus, where is the history of the last accessed files
2. Via a session file

when I copy the changes from the left file to the right and click on the save button, I've got a message about Cocoa error 1 (see the attached file).

There is no such problem if I select the two files via the Select buttons (and the file selection dialog accordingly) or via drag and drop to the drop zones on the main window.
Steps To ReproduceCase 1:
1. Select the two files from the dropdown menus on the main window.
2. Click Show Diffs.
3. Copy some changes from the left panel to the right.
4. Try to save the changes in the right panel.

Case 2:
1. Open pre-made session file, where the two files are set to be loaded.
2. Copy some changes from the left panel to the right.
3. Try to save the changes in the right panel.
TagsNo tags attached.

Activities

philip_petev

2013-08-24 17:12

reporter  

admin

2013-08-24 17:16

administrator   ~0000340

This bug occurs with any couple of files?
Is the right file on some mounted volume? (NAS, Win Samba on /Volumes folder)

philip_petev

2013-08-24 17:17

reporter   ~0000341

Yes, any couple of files and no, both files and on the local HD.

admin

2013-08-24 17:22

administrator   ~0000342

Do files contain non ASCII characters? Like accented or unicode chars.

Please try with tow very simple file containing only few lines with ASCII chars.

Please, open console.app and see if there is some log message relative to VisualDiffer

philip_petev

2013-08-24 17:26

reporter   ~0000343

I don't think the files I use contain non-ASCII characters, they are pure text file (Distribution scripts for packages, pure xml files).

When I open the console, what I have to look for, how to see only the messages, related only to VisualDiffer?

admin

2013-08-24 17:29

administrator   ~0000344

You can search for 'VisualDiffer' string

just a sample screenshot http://cl.ly/image/3h3h0y2L2m20

philip_petev

2013-08-24 17:46

reporter   ~0000345

Last edited: 2013-08-24 17:49

View 3 revisions

Ok, when I try to reproduce the issue, the log is:

8/24/13 6:38:33.322 PM sandboxd[2220]: ([2213]) VisualDiffer(2213) deny file-read-xattr /Users/philip/ProBook Installer/Resources/Distribution
8/24/13 6:38:33.333 PM sandboxd[2220]: ([2213]) VisualDiffer(2213) deny file-read-xattr /Users/philip/Downloads/HP ProBook Installer/Distribution
8/24/13 6:38:33.345 PM sandboxd[2220]: ([2213]) VisualDiffer(2213) deny file-read-xattr /Users/philip/ProBook Installer/Resources/Distribution
8/24/13 6:38:33.356 PM sandboxd[2220]: ([2213]) VisualDiffer(2213) deny file-read-xattr /Users/philip/Downloads/HP ProBook Installer/Distribution
8/24/13 6:38:58.831 PM sandboxd[2227]: ([2213]) VisualDiffer(2213) deny file-read-xattr /Users/philip/ProBook Installer/Resources/Distribution
8/24/13 6:38:58.841 PM sandboxd[2227]: ([2213]) VisualDiffer(2213) deny file-read-xattr /Users/philip/Downloads/HP ProBook Installer/Distribution
8/24/13 6:38:58.850 PM sandboxd[2227]: ([2213]) VisualDiffer(2213) deny file-read-xattr /Users/philip/ProBook Installer/Resources/Distribution
8/24/13 6:38:58.860 PM sandboxd[2227]: ([2213]) VisualDiffer(2213) deny file-read-xattr /Users/philip/Downloads/HP ProBook Installer/Distribution
8/24/13 6:39:43.928 PM sandboxd[2233]: ([2213]) VisualDiffer(2213) deny file-read-xattr /Users/philip/ProBook Installer/Resources/Distribution
8/24/13 6:39:43.939 PM sandboxd[2233]: ([2213]) VisualDiffer(2213) deny file-read-xattr /Users/philip/Downloads/HP ProBook Installer/Distribution
8/24/13 6:39:43.949 PM sandboxd[2233]: ([2213]) VisualDiffer(2213) deny file-read-xattr /Users/philip/ProBook Installer/Resources/Distribution
8/24/13 6:39:43.959 PM sandboxd[2233]: ([2213]) VisualDiffer(2213) deny file-read-xattr /Users/philip/Downloads/HP ProBook Installer/Distribution
8/24/13 6:39:45.322 PM sandboxd[2233]: ([2213]) VisualDiffer(2213) deny file-write-data /Users/philip/Downloads/HP ProBook Installer/Distribution
8/24/13 6:40:24.762 PM sandboxd[2239]: ([2213]) VisualDiffer(2213) deny file-read-xattr /Users/philip/ProBook Installer/Resources/Distribution
8/24/13 6:40:24.769 PM sandboxd[2239]: ([2213]) VisualDiffer(2213) deny file-read-xattr /Users/philip/Downloads/HP ProBook Installer/Distribution
8/24/13 6:40:24.779 PM sandboxd[2239]: ([2213]) VisualDiffer(2213) deny file-read-xattr /Users/philip/ProBook Installer/Resources/Distribution
8/24/13 6:40:24.790 PM sandboxd[2239]: ([2213]) VisualDiffer(2213) deny file-read-xattr /Users/philip/Downloads/HP ProBook Installer/Distribution
8/24/13 6:40:28.059 PM sandboxd[2239]: ([2213]) VisualDiffer(2213) deny file-write-data /Users/philip/Downloads/HP ProBook Installer/Distribution

When I open the files with the file selection dialog (the Select button), there is only:

8/24/13 6:41:34.053 PM WindowServer[202]: CGXSetWindowListTags: Modification of kCGSModalWindowTagBit (31) on a window 0x12d requiring rights kCGSWindowRightOwner by caller VisualDiffer
8/24/13 6:41:34.055 PM WindowServer[202]: CGXSetWindowShadowParameters: Operation on a window 0x12d requiring rights kCGSWindowRightOwner by caller VisualDiffer
8/24/13 6:41:34.256 PM WindowServer[202]: CGXSetWindowShadowParameters: Operation on a window 0x12d requiring rights kCGSWindowRightOwner by caller VisualDiffer
8/24/13 6:41:44.486 PM WindowServer[202]: CGXSetWindowListTags: Modification of kCGSModalWindowTagBit (31) on a window 0x12d requiring rights kCGSWindowRightOwner by caller VisualDiffer
8/24/13 6:41:46.286 PM WindowServer[202]: CGXSetWindowListTags: Modification of kCGSModalWindowTagBit (31) on a window 0x131 requiring rights kCGSWindowRightOwner by caller VisualDiffer
8/24/13 6:41:46.287 PM WindowServer[202]: CGXSetWindowShadowParameters: Operation on a window 0x131 requiring rights kCGSWindowRightOwner by caller VisualDiffer
8/24/13 6:41:46.488 PM WindowServer[202]: CGXSetWindowShadowParameters: Operation on a window 0x131 requiring rights kCGSWindowRightOwner by caller VisualDiffer
8/24/13 6:41:50.374 PM WindowServer[202]: CGXSetWindowListTags: Modification of kCGSModalWindowTagBit (31) on a window 0x131 requiring rights kCGSWindowRightOwner by caller VisualDiffer

and the right file is saved without any errors.
Could it be an issue with the spaces in the file path?

admin

2013-08-24 17:56

administrator   ~0000346

Last edited: 2013-08-24 17:57

View 2 revisions

CGX... messages are not important, are always generated by Apple code

Instead the 'deny file-write-data' means sandbox doesn't allow to write to file but why??

I hate sandbox!!!

Please clean Trusted paths

1. close any open comparison session
2. open Preferences dialog
3. go to Trusted Path tab
4. select all (CMD+A)
5. delete (press the '-' button)
6. restart VisualDiffer
7. Start a new comparison also using a saved session
8. VisualDiffer should prompt to select files again because they aren't known by sandbox
9. try to save changes

thanks for your help and your patience

philip_petev

2013-08-24 18:21

reporter   ~0000347

Ok, I did all ths and tried a few scenarios:

1. Started VisualDiffer and selected the files via the file selection dialog/drag and drop. Copied the changes from left to right, then saved the right file. Worked.
2. Started VisualDiffer and selected the files via the dropdown menu. When I press the Show Diffs button, I've got two file selection windows, labeled Left File Not Accesible and Right File Not Accessible and I had to select them again. Then I copied the changes from left to right and saved the right file. Worked.
3. Started a pre-made session file. I've got these selection windows again, selected them again, copied the changes from left to right and saved the right file. Worked

I cleaned the trusted paths before trying any of these scenarios. When tried scenario 2 and 3 without cleaning the trusted paths, they failed, only scenario 1 works with or without cleaning them. This time I made all these tests in a folder without spaces in the name and I can say the spaces have nothing to do with this issue.

admin

2013-08-24 18:29

administrator   ~0000348

Last edited: 2013-08-24 18:29

View 2 revisions

I noticed sandbox sometimes become not affordable and trusted paths are not correctly recognized but nobody knows why

> When I press the Show Diffs button, I've got two file selection windows, labeled Left File Not Accesible and Right File Not Accessible and I had to select them again

Yes, this really ugly and not user friendly behavior is necessary because you are trying to access to a path (in this case two, left and right) not known by sandbox and the only way to allow sandbox to accept it is to pass from open dialog (or drag and drop but here is not applicable)

> I can say the spaces have nothing to do with this issue

Lucky the filename string isn't a problem, especially if it doesn't contain unicode characters

So everything does work fine now?

philip_petev

2013-08-24 18:35

reporter   ~0000349

No, I still get the Right File Not Accessible window no matter if the files are in the trusted paths or not.

admin

2013-08-24 18:39

administrator   ~0000350

Does console.app shows always the same logs?

Please do a stupid test, swap left with right path. I want to understand if that path has something wrong for VisualDiffer

philip_petev

2013-08-24 18:46

reporter   ~0000351

I've changed the place of the two files and now the left file is not accessible! WTF!!!

both files are called Distribution and it seems the problem is with the source files and not with the destination file. I don't get it, they are pure xml files!!!

admin

2013-08-24 18:52

administrator   ~0000352

Are Unix permissions identical for left and right??

It is a problem related to permission AND sandbox, I've tried to reproduce here but without success

philip_petev

2013-08-24 18:54

reporter   ~0000353

I got it!!! The problem is the second folder in a temporary folder, you see, I use it to extract the content of the package in it, to copy the changes from my pre-made Distribution script to the vanilla one and to assemble the package again. Then I delete this folder, because I don't need it anymore and that's the problem, the destination file never goes to the trusted paths list, simply because this folder doesn't exists anymore.

admin

2013-08-24 18:57

administrator   ~0000354

Last edited: 2013-08-24 18:58

View 2 revisions

Oh ok, if you need this you can simply drag to Trusted Path tab in Preference the root of temporary folder

See more here http://wiki.visualdiffer.com/index.php/Trusted_Paths

Specifically

http://wiki.visualdiffer.com/index.php/Trusted_Paths#Use_trusted_paths

philip_petev

2013-08-24 18:58

reporter   ~0000355

Last edited: 2013-08-24 18:59

View 2 revisions

I've just made a little test: added the folder manually to the trusted pahs list, made the changes to the right file, saved it, which went well, closed VisualDiffer and removed the folder. When I started VisualDiffer again, the folder wasn't in the trusted paths list anymore.
Maybe you should let these paths to stay in this list even if they don't exist anymore.

admin

2013-08-24 19:02

administrator   ~0000356

No longer valid paths are automatically deleted from trusted paths list

philip_petev

2013-08-24 19:04

reporter   ~0000357

Can you make them to stay, maybe with a different color like red, because when the path is restored, it will be valid again?

admin

2013-08-24 19:06

administrator   ~0000358

Good idea, may you file a feature request?

So now everything (and finally) does work fine?

philip_petev

2013-08-24 19:07

reporter   ~0000359

Yes, the problem is tracked down.

Where I can file this request?

admin

2013-08-24 19:10

administrator   ~0000360

Last edited: 2013-08-24 19:10

View 2 revisions

Create a new bug and choose from 'severity' popup the first item 'feature' or simply create the bug then I will set correctly the values

philip_petev

2013-08-24 19:17

reporter   ~0000361

Ok, thank you for your time!

admin

2013-08-24 19:18

administrator   ~0000362

Thank you for your feedback and for you infinite patience

admin

2013-08-25 08:13

administrator   ~0000363

Now I check, before saving, if file exists and if it doesn't exists then show a comprehensive message.

This help users to understand what's happened because "Error 1" doesn't help user or me

Issue History

Date Modified Username Field Change
2013-08-24 17:12 philip_petev New Issue
2013-08-24 17:12 philip_petev Status new => assigned
2013-08-24 17:12 philip_petev Assigned To => admin
2013-08-24 17:12 philip_petev File Added: Screen Shot 2013-08-24 at 1.03.01 PM.png
2013-08-24 17:16 admin Note Added: 0000340
2013-08-24 17:17 philip_petev Note Added: 0000341
2013-08-24 17:22 admin Note Added: 0000342
2013-08-24 17:26 philip_petev Note Added: 0000343
2013-08-24 17:29 admin Note Added: 0000344
2013-08-24 17:46 philip_petev Note Added: 0000345
2013-08-24 17:47 philip_petev Note Edited: 0000345 View Revisions
2013-08-24 17:49 philip_petev Note Edited: 0000345 View Revisions
2013-08-24 17:56 admin Note Added: 0000346
2013-08-24 17:57 admin Note Edited: 0000346 View Revisions
2013-08-24 18:21 philip_petev Note Added: 0000347
2013-08-24 18:29 admin Note Added: 0000348
2013-08-24 18:29 admin Note Edited: 0000348 View Revisions
2013-08-24 18:35 philip_petev Note Added: 0000349
2013-08-24 18:39 admin Note Added: 0000350
2013-08-24 18:46 philip_petev Note Added: 0000351
2013-08-24 18:52 admin Note Added: 0000352
2013-08-24 18:54 philip_petev Note Added: 0000353
2013-08-24 18:57 admin Note Added: 0000354
2013-08-24 18:58 admin Note Edited: 0000354 View Revisions
2013-08-24 18:58 philip_petev Note Added: 0000355
2013-08-24 18:59 philip_petev Note Edited: 0000355 View Revisions
2013-08-24 19:02 admin Note Added: 0000356
2013-08-24 19:04 philip_petev Note Added: 0000357
2013-08-24 19:06 admin Note Added: 0000358
2013-08-24 19:07 philip_petev Note Added: 0000359
2013-08-24 19:10 admin Note Added: 0000360
2013-08-24 19:10 admin Note Edited: 0000360 View Revisions
2013-08-24 19:17 philip_petev Note Added: 0000361
2013-08-24 19:18 admin Note Added: 0000362
2013-08-25 08:13 admin Note Added: 0000363
2013-09-12 17:09 admin Status assigned => closed
2013-09-12 17:09 admin Resolution open => fixed
2013-09-12 17:09 admin Fixed in Version => 1.5.6