View Issue Details

IDProjectCategoryView StatusLast Update
0000222VisualDifferFiles differpublic2014-01-18 08:23
ReportermatthewadamsAssigned Toadmin 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformOSMac OS X MavericksOS Version10.9.1
Product Version 
Target VersionFixed in Version1.5.8 
Summary0000222: Can't directly open file after 'git difftool --dir-diff' due to git's use of symbolic links
DescriptionFirst, I ensured that my VisualDiffer preferences and my session preferences are set to follow symbolic links.

When I run the command 'git difftool --dir-diff', git produces two temporary directories. The first, called "left" represents the HEAD version and contains copies of the files at that version. The second, called "right", contains symbolic links to the currently changed files.

VisualDiffer correctly shows that there are differences between the current files and HEAD. However, when I double click one of the files to view their differences, VisualDiffer prompts me for the location of the file on the right (the symbolically linked file) and the open file dialog lists the two symlinks (see screenshot). If I open the link, VisualDiffer then correctly shows the file differences.

Please have VisualDiffer open the symlinked files directly so that I don't have to open them manually.
TagsNo tags attached.

Activities

matthewadams

2014-01-15 17:30

reporter  

Screen Shot 2014-01-15 at 10.20.45 AM.png (519,091 bytes)

admin

2014-01-15 17:34

administrator   ~0000450

The problem seems related to Apple sandbox and path not accessible from VisualDiffer.

Please take a look at wiki http://wiki.visualdiffer.com/index.php/Trusted_Paths
and configure TrustedPath to allow access to /var/

matthewadams

2014-01-15 17:40

reporter   ~0000451

Just tried that. Same behavior. :(

admin

2014-01-15 17:42

administrator   ~0000452

Please try to add / (whole disk)

matthewadams

2014-01-15 17:43

reporter   ~0000453

The directory "/" was already in my trusted paths.

admin

2014-01-16 09:10

administrator   ~0000454

Are file unix symbolic links or OSX aliases??

I can confirm VD had a bug with aliases, this bug has been fixed but not yet published on MAS.

If the files are aliases and if you want I can send you the beta version so you can help me to test it.

I totally understand if you don't want to be a beta tester.

matthewadams

2014-01-16 13:08

reporter   ~0000457

It looks like they're just plain, old symbolic links:

matthew@newt:~
$ cd /private/var/folders/8z/yrvl9xzn3jl3czsk22sr_kf80000gn/T/git-difftool.1lNGs/right/spring-data-cassandra/src/main/java/org/springframework/data/cassandra/config/xml
matthew@newt:/private/var/folders/8z/yrvl9xzn3jl3czsk22sr_kf80000gn/T/git-difftool.1lNGs/right/spring-data-cassandra/src/main/java/org/springframework/data/cassandra/config/xml
$ ls -al
total 8
drwxr-xr-x 3 matthew staff 102B Jan 16 06:03 .
drwxr-xr-x 4 matthew staff 136B Jan 16 06:03 ..
lrwxr-xr-x 1 matthew staff 175B Jan 16 06:03 CassandraNamespaceHandler.java -> /Users/matthew/Documents/spring-projects/spring-data-cassandra/spring-data-cassandra/src/main/java/org/springframework/data/cassandra/config/xml/CassandraNamespaceHandler.java

You can repro pretty easily: install git, configure VisualDiffer as a difftool, clone a git repo, make a change to a file, then issue the command "git difftool --dir-diff".

admin

2014-01-16 16:04

administrator   ~0000458

My fault, I've a bash alias using "--no-symlinks" for difftool.

You are right, I've reproduced the bug and fixed, too.

If you want I can send to you a version to test.

matthewadams

2014-01-16 17:11

reporter   ~0000461

That's ok. I can workaround until I get the update, unless you want to send me a version with a preview of http://bugs.visualdiffer.com/view.php?id=190, too! :)

Issue History

Date Modified Username Field Change
2014-01-15 17:30 matthewadams New Issue
2014-01-15 17:30 matthewadams Status new => assigned
2014-01-15 17:30 matthewadams Assigned To => admin
2014-01-15 17:30 matthewadams File Added: Screen Shot 2014-01-15 at 10.20.45 AM.png
2014-01-15 17:34 admin Note Added: 0000450
2014-01-15 17:40 matthewadams Note Added: 0000451
2014-01-15 17:42 admin Note Added: 0000452
2014-01-15 17:43 matthewadams Note Added: 0000453
2014-01-16 09:10 admin Note Added: 0000454
2014-01-16 13:08 matthewadams Note Added: 0000457
2014-01-16 16:04 admin Note Added: 0000458
2014-01-16 17:11 matthewadams Note Added: 0000461
2014-01-16 18:14 admin Status assigned => confirmed
2014-01-18 08:20 admin Status confirmed => closed
2014-01-18 08:20 admin Resolution open => fixed
2014-01-18 08:20 admin Product Version 1.5.7 => 1.5.8
2014-01-18 08:23 admin Product Version 1.5.8 =>
2014-01-18 08:23 admin Fixed in Version => 1.5.8