View Issue Details

IDProjectCategoryView StatusLast Update
0000223VisualDifferFiles differpublic2014-02-23 09:25
ReporterjarownAssigned Toadmin 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformMacOSOSXOS VersionMavericks
Product Version 
Target VersionFixed in Version1.5.9 
Summary0000223: Equal files still marked as mismatch with 'Compare file content ignoring line endings'-option
DescriptionWhen I compare two directory-trees I use the 'Compare file content ignoring line endings'-option and select 'Only Mismatches'.

But when I click a 'mismatch' (red filename) no content-differences are found. So that file shouldn't be presented as a mismatch.
Steps To ReproduceSettings:
- Compare the /Unix-LF/ and /DOS-CR-LF/ directories from the attachment (they each contain only 1 file)
- select: 'Compare file content ignoring line endings'
- select: 'Only Mismatches'
- 'README.txt' is marked red
- Doubleclick it (use VisualDiffer diff-tool): no content-differences are found

Things that *are* different:
- timestamp
- filesize (because of different line endings, I assume)
- line endings: DOS (CR+LF) vs Unix (LF)

But since I chose 'compare file content' I'd expect those criteria are ignored.
TagsNo tags attached.

Activities

jarown

2014-01-16 14:28

reporter  

visualdiffer_crlf.zip (6,160 bytes)

admin

2014-01-16 18:13

administrator   ~0000463

The bug has been fixed in v1.5.8 I hope to submit it to Apple in a couple of weeks.

Thanks to attach the test files.

Please apologize for the problem

jarown

2014-01-17 09:05

reporter   ~0000464

Thanks again for the quick reply and fix! Can't wait to get 1.5.8 :)

jarown

2014-02-14 12:53

reporter   ~0000478

I'm afraid the problem is still present in 1.5.8. The example in the currently attached file works fine, but now I have the same problem with another file: marked as different, but no differences found when doubleclicked.

I created a new zip with a new diff-example. Looks like I can't attach it to the issue now.

jarown

2014-02-14 12:55

reporter  

visualdiffer_crlf v2.zip (255,328 bytes)

jarown

2014-02-14 12:55

reporter   ~0000479

Added the new attachment (visualdiffer_crlf v2.zip): README.txt is handled correctly, problem occurs in HTMLPurifier.standalone.php.

Tx in advance!

admin

2014-02-14 13:48

administrator   ~0000480

Tx for your patience and your feedback, I'm investigating why check routine fails.

I will inform you when I fix this bug

admin

2014-02-16 11:13

administrator   ~0000481

Bug fixed, if you find other incorrect matches please send me file or if you prefer I can send to you a version with this bug fix

please apologize me for code regression

jarown

2014-02-17 08:58

reporter   ~0000482

Hi, no problem and thanks again for the quick fix! I'd like to get the version with the fix, so I can betatest it.

admin

2014-02-17 18:01

administrator   ~0000483

Ok, you can find the alpha version at http://cl.ly/001F2N0e1k1a

How to run

1. unzip where you prefer (also your home is fine), do not overwrite the MAS version
2. run and use it

Consider this version contains other modifications under construction so please focus your attention on the "DOS new line" regression

Don't worry if version number is equal to MAS version

Thanks for your infinite patience

jarown

2014-02-18 08:57

reporter   ~0000484

Hi,

I tried this version right away and it works like a charm! Thanks!

Regards,
Jeroen

admin

2014-02-18 09:32

administrator   ~0000485

Oh great!!

I hope to publish 1.5.9 in two weeks.

When I'll publish the fixed version I will close this bug, if you encounter new problem feel free to reopen it (but I hope this time the bug is definitively closed)

Issue History

Date Modified Username Field Change
2014-01-16 14:28 jarown New Issue
2014-01-16 14:28 jarown Status new => assigned
2014-01-16 14:28 jarown Assigned To => admin
2014-01-16 14:28 jarown File Added: visualdiffer_crlf.zip
2014-01-16 18:13 admin Note Added: 0000463
2014-01-16 18:13 admin Status assigned => confirmed
2014-01-17 09:05 jarown Note Added: 0000464
2014-01-18 08:20 admin Status confirmed => closed
2014-01-18 08:20 admin Resolution open => fixed
2014-01-18 08:20 admin Product Version 1.5.7 => 1.5.8
2014-01-18 08:25 admin Product Version 1.5.8 =>
2014-01-18 08:25 admin Fixed in Version => 1.5.8
2014-02-14 12:53 jarown Note Added: 0000478
2014-02-14 12:53 jarown Status closed => feedback
2014-02-14 12:53 jarown Resolution fixed => reopened
2014-02-14 12:55 jarown File Added: visualdiffer_crlf v2.zip
2014-02-14 12:55 jarown Note Added: 0000479
2014-02-14 12:55 jarown Status feedback => assigned
2014-02-14 13:48 admin Note Added: 0000480
2014-02-16 11:13 admin Note Added: 0000481
2014-02-17 08:58 jarown Note Added: 0000482
2014-02-17 18:01 admin Note Added: 0000483
2014-02-18 08:57 jarown Note Added: 0000484
2014-02-18 09:32 admin Note Added: 0000485
2014-02-23 09:25 admin Status assigned => closed
2014-02-23 09:25 admin Resolution reopened => fixed
2014-02-23 09:25 admin Fixed in Version 1.5.8 => 1.5.9