View Issue Details

IDProjectCategoryView StatusLast Update
0000027VisualDifferGeneralpublic2011-01-21 14:30
ReporterLokaganAssigned Toadmin 
PriorityimmediateSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformiMac 10,1OSMacOS XOS Version10.6.6
Product Version 
Target Version1.1Fixed in Version1.1 
Summary0000027: Single a-time operation
DescriptionWhen operating (view, compare, copy), instead of progressive refresh screen, the GUI refresh only when operation is finished. This occurs that is no possibility to operate other operation during one is processing.

TagsNo tags attached.

Relationships

duplicate of 0000018 closedadmin Directory reading hangs up UI when there are many directory or when comparing content 

Activities

admin

2011-01-15 12:42

administrator   ~0000015

Version 1.1 will be more reactive **BUT** the actual implementation doesn't allow to do multiple operation together but it is planned to change current behavior

I hope to release v1.1 in a couple of weeks (plus Apple approval time)

Lokagan

2011-01-15 16:15

reporter   ~0000026

Imagine that the software is use for samba/ftp synchronization (as I use it !), because of "low speed" transfer, the software simply hangup until current process is finishing. At this time, GUI simply freeze until operation is finished... and I have Big files...
Best way to solve "this" is, as I'm thinking, to simply refresh screen after one to one file comparison report.

admin

2011-01-15 16:23

administrator   ~0000027

I've already implemented and it will present in closer version 1.1 a progress indicator file per file.

When a copy (or delete) starts the progress indicator shows
- the current file path
- a progress bar
- the number of files left to copy
- the total amount of bytes (show in the form 123,45KB/MB/GB) left to copy

one 'stop' button so user can cancel the operation in progress.

The panel is modal but the UI isn't frozen because a separated thread processes the progress

Lokagan

2011-01-15 18:37

reporter   ~0000031

In this case, I suggest you to add a pending list of copy operation in order to "simulate" a multitasking application ;)

Issue History

Date Modified Username Field Change
2011-01-15 12:22 Lokagan New Issue
2011-01-15 12:22 Lokagan Status new => assigned
2011-01-15 12:22 Lokagan Assigned To => admin
2011-01-15 12:42 admin Note Added: 0000015
2011-01-15 16:15 Lokagan Note Added: 0000026
2011-01-15 16:23 admin Note Added: 0000027
2011-01-15 18:37 Lokagan Note Added: 0000031
2011-01-20 08:46 admin Relationship added duplicate of 0000018
2011-01-20 08:48 admin Status assigned => resolved
2011-01-20 08:48 admin Resolution open => fixed
2011-01-20 08:55 admin Fixed in Version => 1.1
2011-01-20 08:55 admin Target Version => 1.1
2011-01-21 14:30 admin Status resolved => closed