View Issue Details

IDProjectCategoryView StatusLast Update
0000063VisualDifferFolders differpublic2011-08-22 08:58
ReporterrweingarAssigned Toadmin 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformOSOSX LionOS Version10.7.0
Product Version1.1.4 
Target Version1.1.5Fixed in Version1.1.5 
Summary0000063: Deleting Files Causes Crash in Folder Compare
DescriptionComparing folder contents from left to right with the comparison results displayed, and then choosing to delete files on the right that are no longer on the left causes a program crash.
Steps To Reproduce1. Select two folders to compare, then perform the comparison. The master set of files is on the left.
2. With the results, displayed, select a few of the files from the right side that you wish to delete that are no longer on the left.
3. Right click the selected files then select delete. The files will be deleted and the remaining contents will repaint.
4. Select another few files to delete from the right side then right click and select delete again. The program will crash.
TagsNo tags attached.

Activities

admin

2011-08-16 07:34

administrator   ~0000047

I'm sorry but I'm unable to reproduce the bug.

I've done many tests without reproducing the bug.

Please may you take a look on Console.app to see if there are errors related to VisualDiffer?

To launch Console.app on Lion

1. click on launchpad
2. click on Utilities icon
3. click on Console app
4. search for 'visualdiffer' string

thanks for your feedback

rweingar

2011-08-16 12:56

reporter  

Console_VisualDiffer.log (19,876 bytes)

rweingar

2011-08-16 12:58

reporter   ~0000048

Console log has been uploaded. Please also change the word "cash" in the summary to "crash".

rweingar

2011-08-16 13:22

reporter   ~0000049

Additional information - the directory that I was comparing had approximately 2284 PDF files on the left side and 2350 files on the right side.

admin

2011-08-16 15:30

administrator   ~0000050

The information about huge nr of files allowed me to reproduce the bug.

I'm investigating the problem.

Thanks again for great feedback

Issue History

Date Modified Username Field Change
2011-08-15 23:11 rweingar New Issue
2011-08-15 23:11 rweingar Status new => assigned
2011-08-15 23:11 rweingar Assigned To => admin
2011-08-16 07:34 admin Note Added: 0000047
2011-08-16 12:56 rweingar File Added: Console_VisualDiffer.log
2011-08-16 12:58 rweingar Note Added: 0000048
2011-08-16 13:22 rweingar Note Added: 0000049
2011-08-16 15:29 admin Status assigned => confirmed
2011-08-16 15:29 admin Summary Deleting Files Causes Cash in Folder Compare => Deleting Files Causes Crash in Folder Compare
2011-08-16 15:30 admin Note Added: 0000050
2011-08-19 07:00 admin Resolution open => fixed
2011-08-19 07:00 admin Fixed in Version => 1.1.5
2011-08-19 07:00 admin Target Version => 1.1.5
2011-08-22 08:58 admin Status confirmed => closed